Reply
Want to join in?

Sign in to continue

I have a PSN account

Welcome back!

I'm new!

it only takes a minute or two

  • 121

    New messages in the last hour

  • Get a response within minutes

  • 92%

    92% percent of messages responded to

Accepted Solution

View Original

Problem Solved

View Original Post
15 Jun 2012
By xFlawlessCowboyx
32%
02 Rank
Progress

NAT Problems, very frustrating.

10 Replies 633 Views Created 15-06-2012
15 Jun 2012
By xFlawlessCowboyx

Hi there.

I've been stuck on NAT Type 3 ever since i've got my PS3. I've tried setting up port fowarding on router and such, setting a static ip and even putting the PS3 into DMZ to no avail.

Whenever I am connected to my router either by LAN or Wi-fi I have a NAT type 3 yet when I connect directly to my modem I get a NAT type 2. This leads me to believe that my modem is the cause of the problem so I tried setting up port fowarding on the modem and it made no difference.

 

Modem: THOMSON ST5x6v6

Router: Belkin N600


Any suggestions?

0 Kudos
Reply
LABELS:
View our house rules for posts
Post Reply Update Reply Cancel

Accepted Solution

View Original

Problem Solved

View Original Post
04
/16

adin75

  • Offline
92%
04 Rank
Progress
adin75
Accepted Solution

While I can't give a specific answer, I think this issue has been raised on the forums before. If I recall it's because of the seperate modem and router. The solution involved putting the router into a bridge mode, maybe google how to do that with your model router and give that a try.

 

Edit: I knew I had seen it before, give this thread a read.

 

http://community.eu.playstation.com/t5/PlayStation-3-Technical/Obtaining-NAT-Type-2/td-p/6438874

0 Kudos

Re: NAT Problems, very frustrating.

[ Edited ]

Accepted Solution

View Original

Problem Solved

View Original Post
02
/16
32%
02 Rank
Progress
xFlawlessCowboyx
Accepted Solution

Ok from that last post i've made some progress. My router is a belkin which means I could set as an access point rather than a router meaning it will no longer block any ports. However any attempts to port foward on the modem have no effect on NAT and UPnP is now unavailable according to the PS3 test yet the modem has the setting enabled.

0 Kudos

Re: NAT Problems, very frustrating.

Accepted Solution

View Original

Problem Solved

View Original Post
04
/16

adin75

  • Offline
92%
04 Rank
Progress
adin75
Accepted Solution
Dont worry about UPnP, mine says it's unavailable too, and I have NAT1 so I don't think it's something you need to worry about. Maybe try putting the PS3 back into DMZ and see if that helps rather than worrying about port forwarding (worked for me).
0 Kudos

Re: NAT Problems, very frustrating.

Accepted Solution

View Original

Problem Solved

View Original Post
02
/16
32%
02 Rank
Progress
xFlawlessCowboyx
Accepted Solution

That was the DMZ on the router though. Now the router basically isnt a router any more and i'm not sure if the modem has a DMZ.

0 Kudos

Re: NAT Problems, very frustrating.

Accepted Solution

View Original

Problem Solved

View Original Post
Award Winner
04
/16

RandAPle4

  • Award Winner
  • Offline
95%
04 Rank
Progress
RandAPle4
Accepted Solution

UPnP is quite important for many games that you play online. You also need it for Skype on a PC.

 

As it says in the aforementioned Obtaining NAT Type 2 thread, you should set your Thomson modem into bridge mode but, according to a few other forum threads I've read about your modem, that might not be possible because the modem is sometimes configured automatically by the ISP.

 

Do you get UPnP available when you connect the PS3 directly to the modem? What IP address does the PS3 have when connected this way? Does it get the same IP address when you have it connected via the Belkin in access point mode?

0 Kudos

Re: NAT Problems, very frustrating.

[ Edited ]


regards
Rob
deader than the ANZ forum :( .

Accepted Solution

View Original

Problem Solved

View Original Post
02
/16
32%
02 Rank
Progress
xFlawlessCowboyx
Accepted Solution

Sorry for taking so long to reply.

I have the PS3 set on a static IP so the ip doesn't change at all. The settings I have work both when connect to the router and modem. When connected to the modem itself UPnP is enabled (which I assume allows me to get NAT Type 2).

0 Kudos

Re: NAT Problems, very frustrating.

Accepted Solution

View Original

Problem Solved

View Original Post
Award Winner
04
/16

RandAPle4

  • Award Winner
  • Offline
95%
04 Rank
Progress
RandAPle4
Accepted Solution

UPnP and NAT type do not effect each other. Getting UPnP working won't automatically get you NAT type 2.

UPnP allows the PS3 to automatically configure required ports on the router so that traffic to certain ports from outside the firewall are automatically sent to that host (think "dynamic, automatic and smart port forwarding").

NAT type is harder to explain.

  • NAT type 1 allows only a single host (PC) to hide its local IP address from the internet. All traffic to the public address always goes to the one host.
  • NAT type 2 allows many computers to share a single, public IP address on the internet and packets sent via certain ports on the firewall allow outside hosts to reply to the same port.
  • NAT type 3 is like NAT type 2 but external replies to ports are not automatically allowed (so-called "Strict" NAT).

Using a static IP prevents the PS3 from getting some information from the modem (or  the router). If you need a static IP on the PS3 for port forwarding purposes it is better to set it up as a reserved address on the modem's dhcp server. Use Easy setup on the PS3.

 

0 Kudos

Re: NAT Problems, very frustrating.



regards
Rob
deader than the ANZ forum :( .

Accepted Solution

View Original

Problem Solved

View Original Post
02
/16
32%
02 Rank
Progress
xFlawlessCowboyx
Accepted Solution

Easy setup makes no difference, i'm still stuck with UPnP as unavaliable and NAT type 3.

0 Kudos

Re: NAT Problems, very frustrating.

Accepted Solution

View Original

Problem Solved

View Original Post
Award Winner
04
/16

RandAPle4

  • Award Winner
  • Offline
95%
04 Rank
Progress
RandAPle4
Accepted Solution

Checklist (for belkin as access point only)

 

  1. Turn off dhcp on belkin router
  2. Plug modem into a LAN port on the belkin router (not WAN port)

if that doesnt work you'll have to buy a new modem and router in one.

0 Kudos

Re: NAT Problems, very frustrating.



regards
Rob
deader than the ANZ forum :( .

Accepted Solution

View Original

Problem Solved

View Original Post
Award Winner
03
/16

Lion-Face

  • Award Winner
  • Offline
94%
03 Rank
Progress
Lion-Face
Accepted Solution
The problem is you have two NATs blocking internet traffic. One NAT in the Modem, and one NAT in the Router. I have the same setup and it took me a few months to fix it, I used option 2 from the following as Bridging isn't available in NZ.

You have 1 of 2 options

1: Turn on Bridge mode for your Modem and setup your router to correctly handle bridge mode. This will give you NAT2.

2: Your Modem has an IP Address, your Router has 2 IP Addresses. The 1st IP Address uses the WAN Port and talks ONLY to your Modem. You need to give the WAN Port of the Router a Static IP address. When you give the router a static IP Address, use your Modem and put that Static IP into the Modem's DMZ.

For example, your Thomson modem has an IP Address of 192.168.1.1

Give your Router an IP Address of 192.168.1.10 on it's WAN Port (Or Internet Port as it's sometimes referred to). You will have to give your router a Subnet and Gateway address too.

Find your Thomson Modem's DMZ option and put the address 192.168.1.10 into it.

This will allow your Router to bypass the NAT of the Modem. You are still protected by the NAT of the Router.

-------------------------------------------------------------------

This applies to however you do your previous setup.

Your LAN ports (and Wifi) on your router have their own set of IP address designated by the router. You need to set a static IP for your PS3 and put it into your Router's DMZ.

If your Router's LAN IP is 192.168.0.1 (fairly common)

Then give your PS3 a static IP of 192.168.0.30

Find your Router's DMZ option and put the IP Address of 192.168.0.30 into it.

Clean NAT2 will be your reward.
0 Kudos

Re: NAT Problems, very frustrating.

Photobucket
View our house rules for posts
Post Reply Update Reply Cancel