Want to join in?

Sign in to continue

  • 22

    New messages in the last hour

  • Get a response within minutes

  • 92%

    92% percent of messages responded to

Accepted Solution

View Original

Problem Solved

View Original Post
01 Feb 2008
By Audiomandan


  • Offline
02 Rank

For those stuck with Tversity

0 Replies 7,707 Views Created 01-02-2008
01 Feb 2008
By Audiomandan
Had tried everything to get it working, had been working previously when I had a wireless network but since installing vista and having my pc and PS3 wired to my router just couldn't get it working.

This guide solved it for me so thought I post it here for those still struggling:

My UPnP / DLNA Media Player (this includes the Xbox 360 and the Sony PS3) does not detect the TVersity Media Server or it stops detecting it after a while
Try the following possible solutions in the order they are listed until the problem is solved:

* Make sure the TVersity Media Server is running i.e. the Windows service that corresponds to it, is started. The easiest way to do it is to right click on the TVersity icon in the tray and select “Start Sharing”, alteranatively, go to the start menu and choose “TVersity Tools -> Start TVersity Media Server” option from the TVersity menu. This should open a black window in which the progress of the starting operation will be displayed. If it starts successfully then you most likely have solved your problem. If it says that the server was already running please check the other possible solutions below. If starting the service seems to fail please refer to the next question in this FAQ which deals with problems in getting the media server to start as a service.
* Make sure that the Windows Firewall (and any other personal firewall installed on your computer) does not block the media server from accpeting incoming connections. This is a very common problem so please take the time to check this issue. You will need to make sure that the executable MediaServer.exe located under the installation folder of the software (c:\Program Files\TVersity\Media Server by default) is allowed to accept incoming connections on port 41952 (it is not necessary to specify the port on most personal firewalls).
* Some media players do not allow you to choose which media server to use and therefore you first need to terminate the media server you were using before and only then will the media player be able to identify the TVersity Media Server, please make sure no other media server software is running.
* Stop sharing media via WIndows Media Player 11, the Zune software and Window Media Connect. This is a requirement for Xbox 360 users and a recommendation for users of other devices.
* Make sure that no other program is listening on port 41952 (or if you changed TVersity to use some other port then consider that port instead).
* If the computer running the media server has more than one network interface, you need to make sure that the the TCP binding order on your machine is such that the network interface on which it is supposed to communicate with the media player appears first. Here is how to do that on Windows XP:
o Goto to the Windows Start menu and slect Setting / Network Connections (alternatively open the Network Connections icon from the Windows control panel). This should open a window titled Network Connections.
o In this window go to the main menu and select Advanced / Advanced Settings. This should open a window titled Advanced Settings.
o In this window make sure the Adapters and Bindings tab is selected. Inside this tab under Connections change the order of the network interfaces such that the one you need is first and then click OK.
o Now restart the media server and check if the problem is solved.

Here is the same for Vista:
o Click Start > Network > Network Center > Manage network connections > Click Organize > Layout > click “Classic Menus” > click Advanced (drop down menu)
o Select the adapter whose Binding Order you wish to change in the Connections box.
o Use the arrows on the right side of the Binding for to order the protocols.
o Press OK.
o If you are prompted to restart, press Yes.
* Make sure your router allows multicast traffic and allows UPNP. Some routers block certain types of multicast traffuic or UPNP traffic over a wireles connection even when they are configured not to do so, therefore try using a wired connection (at least for testing purposes) and see if it helps.
* Frequent disconnections in your home network could cause errors with some media players from which they cannot recover without a reboot. Try rebooting your media player (or shutting it off and then turning it back on) and see if the problem persists
* Microsoft Live OneCare is known to disrupt the home network in certain ways that will lead to periodic loss of connectivity between UPnP A/V devices and TVersity. Try disabling it.
* Do you use Pocket PC? Try unplugging it from the USB cradle, some users report TVersity being invisble on their network by their device when their Pocker PC is connected.
* Try putting the media player in media server search mode and then restart the TVersity Media Server from the Windows start menu or from the GUI.
* Try to reboot your computer and your router.

It looks like the TVersity Media Server is not running and I can’t seem to get it started
Try the following possible solutions in the order they are listed until the problem is solved:

* Are you using uTorrent? It has a setting called enable UPnP port mapping which is found under (Options / Preferences / Connections / Enable UPnP Port Mapping), when enabled it appears that it is not possible to use TVersity. When you disable this setting and restart uTorrent and TVersity the service should start fine. If you are using some other P2P software, it may have similar settings, which will need to be disabled.
* Reboot your computer and check again if the service started.
* Uninstall all previous versions of the software and re-install the latest one, then check again if the service started.
* If none of the above worked, power users can try the possible solutions mentioned below, other may need to seek assistance from power users.
* Locate the TVersity menu in the Windows start menu and select “TVersity Tools -> Share Media Command Prompt”. A black command line window will open. In this window please type the command mediaserver -debug and then hit ENTER.
o If no errors are displayed and you do not get back to the command prompt it means that you successfully started the media server as an application. This means that there are some problems with the way the Windows service that corresponds to the TVersity Media Server is configured on your computer. Please try again to uninstall all previous version and re-install the latest, this should fix the problem.
o If a message box was displayed with the error message "The application failed to initialize properly (0xc0150002). Click on OK to terminate the application." then you are having a well known Microsoft Windows related issue that is described by Micrsosoft as some mismatch with runtime libraries related to a recent service pack installation. The solution they suggest is to re-install the latest Windows Service Pack and then restart the computer. For more information please click here.
0 Kudos
View our house rules for posts
Post Reply Update Reply Cancel
View our house rules for posts
Post Reply Update Reply Cancel